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1. Introduction 
The Roon Device Module provides the following: 
 

● Browsing of Roon’s Library and Music Services from Crestron 
○ Library 
○ TIDAL  
○ Search 
○ Playlists 
○ Genre Browsing 

● Control of Roon’s zones from Crestron 
○ Transport controls 
○ Now Playing information 
○ Volume/Mute controls 
○ Standby 

 
There are two modules: the Roon Device Module which talks to an individual output device, and 
the Roon System Module which manages the connection to the Roon system. 
 
Roon’s module includes a Crestron MediaPlayer implementation, as well as transport and now 
playing informations exposed via Joins to facilitate custom interfaces. 
 
These drivers are compatible with Roon 1.4 (build 306) and above. 
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2. General Information: 
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SIMPLWINDOWS NAME: RoonDeviceModule 

CATEGORY: Media Resource 

VERSION: V. 1.0 (Build 8) 

SUMMARY: This module is used to control an audio 
player through Roon 

GENERAL NOTES:  

CRESTRON HARDWARE REQUIRED: 3-Series processor 
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3. Getting Started with the Demo Program 
This package includes a demo program, which shows you how to hook up the Media Player to 
the Roon modules.  
 
1. Download the control system and virtual panel programs: 

a. Download the archive here: 
https://download.roonlabs.com/crestron/Roon_Example_Compiled.zip  
OR 
https://download.roonlabs.com/crestron/Roon_Example_Archived.zip  
Note: If unfamiliar with Crestron archives, please use the Compiled Version 

b. Unzip the archive. 
 

2. Start the Crestron Toolbox, and connect to your 3-series control system.  If it is not in 
your address book already, do this: 
 

a. Open the “Device Discovery Tool”, the binoculars icon on the top toolbar 
b. Wait for it to discover your control system 
c. Right click on the control system in the list at the left of the screen, and select “Add 

Hostname to Current Address Book” 
 

3. Switch to the “Easy Config” tool, the “EC” icon on the top toolbar.  
 

● Select the control system from the address book menu in the bottom left of the screen. 
● Transfer the control system program, by clicking “Program”, clicking “Browse” in the pop 

window, then navigating to the “Roon_Example_CP3.lpz” file from the archive, selecting 
it, and clicking “Send” 
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4. Enable the Crestron Extension in Roon settings 
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5. Select an output to pair with the Crestron device by clicking “Settings” and picking an 
output in the dropdown menu. 
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6. Run the “Roon Example TSW-750.vtz” program as a virtual panel: 
 

a. Double click on the program in Windows Explorer 
b. Select Options -> Host Settings, enter the IP address of the Crestron Control system and 

set “IPID” to “03” 
c. Click “Connect” 

 
 
7. Select the desired zone to view the demo screen. 
 

(1) Main screen 
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(2) Mediaplayer screen 
 

 
8. If you are upgrading from a previous Roon Crestron build, please follow these 
instructions for proper communication: 
 

a. Update Nucleus and Roon Remotes to the newest Roon version 
b. Unauthorize any existing Crestron extension in Roon Settings -> Extensions -> View 
c. Add the Nucleus' IP address in the Crestron module RoonSystemModule symbol  
d. Compile and upload the module to the processor 
e. Reboot the Nucleus from the WebUI or power button 
f. Enable/Pair the new module in Roon Settings -> Extensions 
g. Configure the new module in Roon Settings -> Extensions 
h. Reboot the Nucleus again after the module is paired 
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4. Controls: 
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SystemModuleReady D Indicates that the system module is up and operating, 
the device module won’t operate until this is set 

StandBy D Pulse to put the audio hardware controlled by this 
module to standby mode 

ConvenienceSwitch D Pulse to take the audio hardware controlled by this 
module out of standby mode and do anything required 
to get it ready to play 

Play D Pulse to play music 

Pause D Pulse to pause music 

Play/Pause D Pulse to toggle between play and pause state 

NextTrack D Pulse to switch to the next track 

PreviousTrack D Pulse to switch to the previous track 

Stop D Pulse to stop music 

SetShuffleOn D Pulse to set shuffle mode to on 

SetShuffleOff D Pulse to set shuffle mode to off 

ToggleShuffle D Pulse to toggle shuffle mode between off and on 

SetLoop D Pulse to set loop mode to loop the whole current queue 

SetLoopOne D Pulse to set loop mode to loop the current track 

SetLoopOff D Pulse to set loop mode to none 

ToggleLoop D Pulse to toggle between loop modes, in this order: 
whole queue -> current track -> none 

SetAutoRadioOn D Pulse to turn on auto radio, so that Roon will 
automatically enable radio mode when the current 
queue ends 

SetAutoRadioOff D Pulse to turn off auto radio 

ToggleAutoRadio D Pulse to toggle auto radio 

VolumeUp D Pulse to increase volume slightly 
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VolumeDown D Pulse to decrease volume slightly 

Volume A Set the volume in the device’s native units 

VolumeNormalized A Set the volume in a normalized scale between 0 and 
65535 

Mute D Pulse to mute the audio 

Unmute D Pulse to unmute the audio 

Mute/Unmute D Pulse to toggle mute on/off 

Seek A Seek to a position in the track, in seconds units 

SeekNormalized A Seek to a position in the track, in normalized scale 
between 0 and 65535 

CRPC S To be connected to the Media Server Object Router 
module 



11 

5. Feedback: 
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IsAvailable_fb D Set to high when the device module is available and 
functioning correctly 

SupportsStandby_fb D Set to high if the hardware connected to this device 
module supports a standby mode 

SupportsConvenienceSwitch
_fb 

D Set to high if the hardware connected to this device 
module supports convenience switching 

Name_fb S The name of the audio zone in Roon 

IsPlayAllowed_fb D Set to high if the play action is available 

IsPauseAllowed_fb D Set to high if the pause action is available 

IsNextAllowed_fb D Set to high if the next track action is available 

IsPreviousAllowed_fb D Set to high if the previous action is available 

Playing_fb D Set to high if music is playing 

Paused_fb D Set to high if music is paused 

Loading_fb D Set to high if a file is loading 

Stopped_fb D Set to high if music is stopped 

IsShuffle_fb D Set to high if shuffle mode is active 

IsLoop_fb D Set to high if the loop mode is to loop the whole 
queue 

IsLoopOne_fb D Set to high if the loop mode is to loop a single track 

IsAutoRadio_fb D Set to high if auto radio mode is active, so that Roon 
will go to radio mode automatically when the queue 
ends 

VolumeMin_fb A Minimum possible volume level, in the hardware’s 
native units 

VolumeMax_fb A Maximum possible volume level, in the hardware’s 
native units 

Volume_fb A Current volume, in the hardware’s native units 
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VolumeNormalized_fb A Current volume, normalized to a range between 0 and 
65535 

VolumeType_fb S Volume type, as a string.  Possible values are 
"number", "db", "incremental".  If you get an 
unanticipated value, treat it as “number” 

IsVolumeFixed_fb D Set to high if the hardware volume is fixed and cannot 
be controlled through Roon 

IsMuted_fb D Set to high if muted 

IsSeekAllowed_fb D Set to high if seeking is possible in the current track 

PositionSeconds_fb A Position in the current track in seconds 

PositionNormalized_fb A Position in the current track, normalized to a range 
between 0 and 65535 

PositionSerial_fb S Position in the current track, as a string suitable for 
displaying to users.  Formatted like 1:23:45 a position 
of 1 hour, 23 minutes and 45 seconds into a track 

LengthSeconds_fb A Length of the current track, in seconds 

LengthSerial_fb S Length the current track, as a string suitable for 
displaying to users.  Formatted like 1:23:45 a position 
of 1 hour, 23 minutes and 45 seconds into a track 

ShowSeekPosition_fb D Set to high if there is a meaningful seek position for 
the current track 

ShowLength_fb D Set to high if there is a meaningful length for the 
current track 

OneLine_fb S Now playing track information formatted for a single 
line display 

TwoLine_Line1_fb S First line of the now playing track information 
formatted for a two line display 

TwoLine_Line2_fb S Second line of the now playing track information 
formatted for a two line display 

ThreeLine_Line1_fb S First line of the now playing track information 
formatted for a three line display 

ThreeLine_Line2_fb S Second line of the now playing track information 
formatted for a three line display 



13 

 

  

Version 1.0 (Build 10) 
© 2018 Roon Labs, LLC 

 

ThreeLine_Line3_fb S Third line of the now playing track information 
formatted for a three line display 

NowPlayingImageUrl_fb S URL for the artwork to be shown with the currently 
playing track 

PlayBackError_fb S Error message for the currently playing track 

CRPC_fb S To be connected to the Media Server Object Router 
module 
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6. Testing 
This module was tested by Roon Labs with  the following versions, and is known to work: 
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OPS used for testing V. 1.502.0039.001 

SIMPL Windows used for testing V. 4.08.15 

Crestron DB used for testing V. 64.05.001.00 

Device DB used for testing V. 88.05.003.00 

Sample program Roon Media Player v1.0 (Build 10) 

Revision history V 1.0 (Build 10): 
• Rebuilt to work with Crestron Database 
version 200 and higher 
 
V 1.0 (Build 10): 
• You are now required to place the Nucleus 
IP address in the RoonSystemModule symbol 
and it is recommended that this IP does not 
change 
• Added support for processors with Control 
Subnets such as CP3N, PRO3 & AV3  
• Improved TIDAL Search functionality 
• Added Qobuz functionality to module  
• Fixed issue with duplicate zones appearing 
in Roon -> Extension Settings 
• Fixed zone names sometimes failing to 
appear in interface's home screen 
• Fixed issue with Explore Menu sometimes 
not loading 
• Added ability to jump to iOS Roon App in 
iPhone/iPad interfaces (linked to press5 on 
both IPID 05 and IPID 06) 
• Updated Home/App icons 
 
 
V 1.0 (Build 7): 
• Performance Improvements 
• Added home button for easier navigation 
• Duplicate Zones appearing has been fixed 
• Added version numbers in project 
• Improved Volume Control logic for analog 
ramps 
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V 1.0 (Build 6): 
• Performance Improvements  
• Added 4th Audio Zone 
• Zone names update automatically 
• MuteAll/PauseAll commands implemented 
• Module allowed to reside in other SIMPL 
subfolders 
• EnableDebugMode set by default to off 
 
V 1.0 (Build 5): 
• Added Multi-zone Support 
• Added Compiled and Archived Editions 
• Added iPhone/iPad VTPro Samples 
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7. FAQ 
 
Q: The Controls for a Zone are not working, the module just seems to be loading but 
nothing is happening!  
 
A: Please make sure that the device is powered on and that it shows up as an active audio zone 
in the Roon Settings 
 
Q: I cannot control the Volume through the Crestron Module! 
 
A: Please make sure that your Zone Output supports the ability to change the volume from 
within Roon and is not a “Fixed Volume” device 
 
Q: How do I set the Zone Outputs for my devices?  
 
A: Please open Roon -> Settings -> Extensions -> Crestron Settings and set your Zones there 
 
Q: I don’t the Crestron Module listed in Roon -> Settings -> Extensions! 
 
A: Please make sure that you Nucleus is powered on and connected to the network when you 
performed the upload. You can also perform a “Recompile All” in SIMPL and then upload the 
Sample Project to your processor once more. If there is nothing listed under Roon Extensions, 
then the module is not communicating properly and a re-upload of the project is needed.  
 
Q: What is the difference between the “Compiled” and “Archived” version of the Sample 
Project? 
 
A: The compiled version is ready for upload, the archived version has to first be extracted, then 
the Compiled VTPro project files have to be linked from within SIMPL. If you are not sure which 
version to use, please download the Compiled edition.  
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8. Support 
 

If you’re having any trouble with this module, please get ​get in touch with Roon Support​ in our 
Home Automation section of Community​. 
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